How do I use dd command to create an ISO image?
Put CD into CDROM
Do not mount CD. Verify if cd is mounted or not with mount command:
# mount
If cd was mouted automatically unmout it with umount command:
# umount /dev/cdrom
OR
# umount /mnt/cdrom
Create CD-ROM ISO image with dd command:
# dd if=/dev/cdrom of=/tmp/cdimg1.iso
Mounting ISO in AIX-
Starting in AIX 6.1, you can use the loopmount command to create a loopback device and mount an ISO directly:
#loopmount -i cdrom.iso -o “-V cdrfs -o ro” -m /mnt
And, loopumount unmounts the ISO and removes the loopback device:
#loopumount -i cdrom.iso -o "/mnt"
There are a couple of gotcha's, but nothing unusual. An ISO can only be associated with one loopback device at a time,
the mount is only readonly, and it's not supported in WPARs.
There is another way to mount those images, but it's not a one-step process.
What you need to do is create a LV at least as big as your ISO image,
then copy the ISO data to that LV, and then mount the LV:
#mklv -y cdlv -s n rootvg 704M hdisk0
#dd if=cdrom.iso of=/dev/cdlv
#mount -v cdrfs -o ro /dev/cdlv /mnt
- UNIX Essential Skills
- UNIX Basic Commands
- Different RUN levels in Linux,Solaris and AIX
- Determine if your OS is 64-bit or 32-bit?
- How to find your MAC Add: Unix/Linux/Windows/Mac
- VI Editor Quick Reference
- dd command to create an ISO image
- TOP command - Useful switch
- Configure NTP server for time adjustment
- How to find larger file under Linux
- Adding a Swap File to an RHEL6 System
- How to find if its VM or Real host
- Find Files Based on Access/Modification/Change Time
- LINUX
- AIX
- SOLARIS
- Storage Area Network (SAN)
- NAS Netapp
- BACKUP Admin
No comments:
Post a Comment